Security update for gnutls

SUSE Security Update: Security update for gnutls
Announcement ID: SUSE-SU-2014:0321-1
Rating: critical
References: #865804 #865993
Affected Products:
  • SUSE Linux Enterprise Server 10 SP4 LTSS

  • An update that solves one vulnerability and has one errata is now available.


    The GnuTLS library received a critical security fix and
    other updates:

    * CVE-2014-0092: The X.509 certificate verification had
    incorrect error handling, which could lead to broken
    certificates marked as being valid.
    * CVE-2009-5138: A verification problem in handling V1
    certificates could also lead to V1 certificates incorrectly
    being handled.

    Security Issue references:

    * CVE-2014-0092

    Package List:

    • SUSE Linux Enterprise Server 10 SP4 LTSS (i586 s390x x86_64):
    • gnutls-1.2.10-13.38.1
    • gnutls-devel-1.2.10-13.38.1
    • SUSE Linux Enterprise Server 10 SP4 LTSS (s390x x86_64):
    • gnutls-32bit-1.2.10-13.38.1
    • gnutls-devel-32bit-1.2.10-13.38.1