Security update for rubygem-actionpack-2_3

SUSE Security Update: Security update for rubygem-actionpack-2_3
Announcement ID: SUSE-SU-2014:0153-1
Rating: moderate
References: #853632
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2

  • An update that fixes four vulnerabilities is now available. It includes one version update.

    Description:


    This update fixes the following security issues with
    rubygem-actionpack:

    * CVE-2013-6415: rubygem-actionpack: number_to_currency
    XSS (bnc#853632).

    Security Issue references:

    * CVE-2013-4491
    >
    * CVE-2013-6417
    >
    * CVE-2013-6415
    >
    * CVE-2013-6414
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-rubygem-actionpack-2_3-8702

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New Version: 2.3.17]:
    • rubygem-actionpack-2_3-2.3.17-0.13.2

    References:

    • http://support.novell.com/security/cve/CVE-2013-4491.html
    • http://support.novell.com/security/cve/CVE-2013-6414.html
    • http://support.novell.com/security/cve/CVE-2013-6415.html
    • http://support.novell.com/security/cve/CVE-2013-6417.html
    • https://bugzilla.novell.com/853632
    • http://download.novell.com/patch/finder/?keywords=eed33b2944b04d2b779d8d32db4cc8e3