Security update for libzypp

SUSE YOU Update: Security update for libzypp
Announcement ID: SUSE-YU-2013:1408-1
Rating: important
References: #828672
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP3
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Linux Enterprise Server 11 SP3 for VMware
  • SUSE Linux Enterprise Server 11 SP3
  • SUSE Linux Enterprise Server 11 SP2 for VMware
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP3
  • SUSE Linux Enterprise Desktop 11 SP2

  • An update that fixes one vulnerability is now available. It includes two new package versions.

    Description:


    libzypp did not handle multiple gpg pubkeys in the
    repomd.xml.key and content.key consistently and secure.
    Attackers could have exploited this to add their own keys
    and pretend it's from SUSE.

    Security Issue reference:

    * CVE-2013-3704
    >

    Special Instructions and Notes:

    This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application. This update triggers a restart of the software management stack. More updates will be available for installation after applying this update and restarting the application.

    Patch Instructions:

    To install this SUSE YOU Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP3:
      zypper in -t patch sdksp3-libzypp-8232
    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-libzypp-8231
    • SUSE Linux Enterprise Server 11 SP3 for VMware:
      zypper in -t patch slessp3-libzypp-8232
    • SUSE Linux Enterprise Server 11 SP3:
      zypper in -t patch slessp3-libzypp-8232
    • SUSE Linux Enterprise Server 11 SP2 for VMware:
      zypper in -t patch slessp2-libzypp-8231
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp2-libzypp-8231
    • SUSE Linux Enterprise Desktop 11 SP3:
      zypper in -t patch sledsp3-libzypp-8232
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp2-libzypp-8231

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64 s390x x86_64) [New Version: 9.37.1]:
    • libzypp-devel-9.37.1-0.7.1
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New Version: 9.16.1]:
    • libzypp-devel-9.16.1-0.5.1
    • SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64) [New Version: 9.37.1]:
    • libzypp-9.37.1-0.7.1
    • SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64) [New Version: 9.37.1]:
    • libzypp-9.37.1-0.7.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64) [New Version: 9.16.1]:
    • libzypp-9.16.1-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New Version: 9.16.1]:
    • libzypp-9.16.1-0.5.1
    • SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64) [New Version: 9.37.1]:
    • libzypp-9.37.1-0.7.1
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64) [New Version: 9.16.1]:
    • libzypp-9.16.1-0.5.1

    References:

    • http://support.novell.com/security/cve/CVE-2013-3704.html
    • https://bugzilla.novell.com/828672
    • http://download.suse.com/patch/finder/?keywords=f0c3c756b6f7adc654f65bab07dbfa5d
    • http://download.suse.com/patch/finder/?keywords=f381dfd1d557b77879a92be2ddf5be54