Security update for strongswan

SUSE Security Update: Security update for strongswan
Announcement ID: SUSE-SU-2013:1866-3
Rating: moderate
References: #833278 #840826 #847506
Affected Products:
  • SUSE Linux Enterprise Server 10 SP4 LTSS

  • An update that solves one vulnerability and has two fixes is now available.


    This strongswan update fixes security issues and bugs:

    * CVE-2013-5018: Specially crafted XAuth usernames and
    EAP identities can cause a crash in strongswan.
    * CVE-2013-6075: A crafted ID packet can be used by
    remote attackers to crash the server or potentially gain
    authentication privileges under certain circumstances.

    Also a bug with route recursion limits was fixed:

    * Charon SEGFAULT when left=%any / recursion limit

    Security Issues:

    * CVE-2013-5018

    Package List:

    • SUSE Linux Enterprise Server 10 SP4 LTSS (i586 s390x x86_64):
    • strongswan-4.4.0-6.15.1
    • strongswan-doc-4.4.0-6.15.1