Security update for gpg2

SUSE Security Update: Security update for gpg2
Announcement ID: SUSE-SU-2013:1576-1
Rating: low
References: #840510 #844175
Affected Products:
  • SUSE Linux Enterprise Server 11 SP3 for VMware
  • SUSE Linux Enterprise Server 11 SP3
  • SUSE Linux Enterprise Server 11 SP2 for VMware
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP3
  • SUSE Linux Enterprise Desktop 11 SP2

  • An update that fixes two vulnerabilities is now available.

    Description:


    This GnuPG update fixes two security issues:

    * CVE-2013-4351: GnuPG treated no-usage-permitted keys
    as all-usages-permitted.
    * CVE-2013-4402: An infinite recursion in the
    compressed packet parser was fixed.

    Security Issue references:

    * CVE-2013-4351
    >
    * CVE-2013-4402
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 11 SP3 for VMware:
      zypper in -t patch slessp3-gpg2-8427
    • SUSE Linux Enterprise Server 11 SP3:
      zypper in -t patch slessp3-gpg2-8427
    • SUSE Linux Enterprise Server 11 SP2 for VMware:
      zypper in -t patch slessp2-gpg2-8426
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp2-gpg2-8426
    • SUSE Linux Enterprise Desktop 11 SP3:
      zypper in -t patch sledsp3-gpg2-8427
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp2-gpg2-8426

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1
    • SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1
    • SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):
    • gpg2-2.0.9-25.33.37.1
    • gpg2-lang-2.0.9-25.33.37.1

    References:

    • http://support.novell.com/security/cve/CVE-2013-4351.html
    • http://support.novell.com/security/cve/CVE-2013-4402.html
    • https://bugzilla.novell.com/840510
    • https://bugzilla.novell.com/844175
    • http://download.suse.com/patch/finder/?keywords=1a9216ce39dd2871a8d6e5b39203e766
    • http://download.suse.com/patch/finder/?keywords=62c1b5dafafed1d8aa2a8a1d3f9d2f4f