Security update for ceph-kmp

SUSE Security Update: Security update for ceph-kmp
Announcement ID: SUSE-SU-2013:1161-1
Rating: important
References: #750047 #756193 #826350
Affected Products:
  • SUSE Cloud 1.0

  • An update that solves one vulnerability and has two fixes is now available.


    This ceph-kmp update fixes a libceph NULL function pointer
    dereference. Here is the full list of changes:

    * bug#826350 - libceph NULL function pointer
    dereference (CVE-2013-1059)
    * bug#750047 - marking ceph-kmp as supported
    * bug#756193 - fix for libceph crash

    Security Issue reference:

    * CVE-2013-1059

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Cloud 1.0:
      zypper in -t patch sleclo10sp2-ceph-kmp-default-7980

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Cloud 1.0 (x86_64):
    • ceph-kmp-default-0_3.0.80_0.7-
    • ceph-kmp-xen-0_3.0.80_0.7-