Security update for rubygem-json_pure

SUSE Security Update: Security update for rubygem-json_pure
Announcement ID: SUSE-SU-2013:0609-2
Rating: important
References: #803342
Affected Products:
  • WebYaST 1.3
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Lifecycle Management Server 1.3

  • An update that fixes one vulnerability is now available.

    Description:


    The json_pure Ruby Gem has been updated to fix a Denial of
    Service and Unsafe Object Creation Vulnerability in JSON
    (CVE-2013-0269)

    * Entity expansion DoS vulnerability in REXML (XML bomb)

    Security Issues:

    * CVE-2013-0269
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • WebYaST 1.3:
      zypper in -t patch slewyst13-rubygem-json_pure-7527
    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-rubygem-json_pure-7527
    • SUSE Lifecycle Management Server 1.3:
      zypper in -t patch sleslms13-rubygem-json_pure-7527

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • WebYaST 1.3 (i586 ia64 ppc64 s390x x86_64):
    • rubygem-json_pure-1.2.0-0.4.4
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • rubygem-json_pure-1.2.0-0.4.4
    • SUSE Lifecycle Management Server 1.3 (x86_64):
    • rubygem-json_pure-1.2.0-0.4.4

    References:

    • http://support.novell.com/security/cve/CVE-2013-0269.html
    • https://bugzilla.novell.com/803342
    • http://download.suse.com/patch/finder/?keywords=59c25e19a4a6f534d0c992634f28b511