Security update for rubygem-json_pure

SUSE Security Update: Security update for rubygem-json_pure
Announcement ID: SUSE-SU-2013:0609-1
Rating: important
References: #803342
Affected Products:
  • WebYaST 1.2
  • SUSE Studio Standard Edition 1.2
  • SUSE Studio Extension for System z 1.2

  • An update that fixes one vulnerability is now available.


    The json_pure Ruby Gem has been updated to fix a Denial of
    Service and Unsafe Object Creation vulnerability in JSON

    Additional fixes:

    * Entity expansion DoS vulnerability in REXML (XML bomb)

    Security Issue reference:

    * CVE-2013-0269

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • WebYaST 1.2:
      zypper in -t patch slewyst12-rubygem-json_pure-7486
    • SUSE Studio Standard Edition 1.2:
      zypper in -t patch sleslms12-rubygem-json_pure-7486
    • SUSE Studio Extension for System z 1.2:
      zypper in -t patch slestso12-rubygem-json_pure-7486

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • WebYaST 1.2 (i586 ia64 ppc64 s390x x86_64):
    • rubygem-json_pure-1.2.0-0.4.1
    • SUSE Studio Standard Edition 1.2 (x86_64):
    • rubygem-json_pure-1.2.0-0.4.1
    • SUSE Studio Extension for System z 1.2 (s390x):
    • rubygem-json_pure-1.2.0-0.4.1