Security update for PostgreSQL

SUSE Security Update: Security update for PostgreSQL
Announcement ID: SUSE-SU-2013:0517-1
Rating: moderate
References: #802679
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Linux Enterprise Server 11 SP2 for VMware
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP2

  • An update that fixes one vulnerability is now available. It includes two new package versions.

    Description:


    PostgreSQL has been updated to version 9.1.8 which fixes
    various bugs and one security issue.

    The security issue fixed in this release, CVE-2013-0255,
    allowed a previously authenticated user to crash the
    server by calling an internal function with invalid
    arguments. This issue was discovered by the independent
    security researcher Sumit Soni this week and reported via
    Secunia SVCRP, and we are grateful for their efforts in
    making PostgreSQL more secure.

    More information can be found at

    http://www.postgresql.org/about/news/1446/


    Security Issue reference:

    * CVE-2013-0255
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-libecpg6-7342
    • SUSE Linux Enterprise Server 11 SP2 for VMware:
      zypper in -t patch slessp2-libecpg6-7342 slessp2-postgresql-7340
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp2-libecpg6-7342 slessp2-postgresql-7340
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp2-libecpg6-7342 sledsp2-postgresql-7340

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New Version: 9.1.8]:
    • postgresql91-devel-9.1.8-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64) [New Version: 8.3.23 and 9.1.8]:
    • libecpg6-9.1.8-0.5.1
    • libpq5-9.1.8-0.5.1
    • postgresql-8.3.23-0.4.1
    • postgresql-contrib-8.3.23-0.4.1
    • postgresql-docs-8.3.23-0.4.1
    • postgresql-server-8.3.23-0.4.1
    • postgresql91-9.1.8-0.5.1
    • postgresql91-contrib-9.1.8-0.5.1
    • postgresql91-docs-9.1.8-0.5.1
    • postgresql91-server-9.1.8-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (x86_64) [New Version: 9.1.8]:
    • libpq5-32bit-9.1.8-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New Version: 8.3.23 and 9.1.8]:
    • libecpg6-9.1.8-0.5.1
    • libpq5-9.1.8-0.5.1
    • postgresql-8.3.23-0.4.1
    • postgresql-contrib-8.3.23-0.4.1
    • postgresql-docs-8.3.23-0.4.1
    • postgresql-server-8.3.23-0.4.1
    • postgresql91-9.1.8-0.5.1
    • postgresql91-contrib-9.1.8-0.5.1
    • postgresql91-docs-9.1.8-0.5.1
    • postgresql91-server-9.1.8-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 (ppc64 s390x x86_64) [New Version: 9.1.8]:
    • libpq5-32bit-9.1.8-0.5.1
    • SUSE Linux Enterprise Server 11 SP2 (ia64) [New Version: 9.1.8]:
    • libpq5-x86-9.1.8-0.5.1
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64) [New Version: 8.3.23 and 9.1.8]:
    • libecpg6-9.1.8-0.5.1
    • libpq5-9.1.8-0.5.1
    • postgresql-8.3.23-0.4.1
    • postgresql91-9.1.8-0.5.1
    • SUSE Linux Enterprise Desktop 11 SP2 (x86_64) [New Version: 9.1.8]:
    • libpq5-32bit-9.1.8-0.5.1

    References:

    • http://support.novell.com/security/cve/CVE-2013-0255.html
    • https://bugzilla.novell.com/802679
    • http://download.suse.com/patch/finder/?keywords=c3212d7df41878fb9f2807cfcf4855ee
    • http://download.suse.com/patch/finder/?keywords=cd006fe2067b8aff8ca70a034368785a