Security update for openstack-glance

SUSE Security Update: Security update for openstack-glance
Announcement ID: SUSE-SU-2013:0401-1
Rating: moderate
References: #787814 #800023
Affected Products:
  • SUSE Cloud 1.0

  • An update that fixes two vulnerabilities is now available.


    OpenStack Glance has been updated to fix a password leak.

    It has also been updated to the latest git version
    (efd7e75) which includes:

    * pin sqlalchemy to the 0.7 series
    * Ensure image owned by user before delayed_deletion

    Security Issue references:

    * CVE-2013-0208
    * CVE-2013-0212

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Cloud 1.0:
      zypper in -t patch sleclo10sp2-openstack-glance-7313

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Cloud 1.0 (x86_64):
    • openstack-glance-2012.1+git.1352338057.efd7e75-0.5.1
    • python-glance-2012.1+git.1352338057.efd7e75-0.5.1