Recommended update for valgrind

SUSE Recommended Update: Recommended update for valgrind
Announcement ID: SUSE-RU-2013:0218-1
Rating: low
References: #776211
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2

  • An update that has one recommended fix can now be installed. It includes one version update.


    This update provides valgrind 3.8.1, which adds support for

    * Support for Intel AVX instructions and for AES
    instructions. This support is available only for 64 bit
    * Support for POWER Decimal Floating Point instructions
    * Non-libc malloc implementations are now supported
    * Tool developers can make replacement/wrapping more
    flexible thanks to the new option --soname-synonyms
    * The C++ demangler has been updated so as to work well
    with C++ compiled by up to at least g++ 4.6.
    * Increased limit for the --num-callers command line
    flag to 500
    * Improved support for DWARF4 debugging information
    * Initial support for DWZ compressed Dwarf debug info
    * Modest performance gains through the use of
    translation chaining
    * Several improvements for s390x.



    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-valgrind-7010

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ppc64 s390x x86_64) [New Version: 3.8.1]:
    • valgrind-3.8.1-0.5.1
    • valgrind-devel-3.8.1-0.5.1