Security update for openstack-keystone

SUSE Security Update: Security update for openstack-keystone
Announcement ID: SUSE-SU-2012:1675-1
Rating: moderate
References: #783036 #783200 #791203
Affected Products:
  • SUSE Cloud 1.0

  • An update that solves one vulnerability and has two fixes is now available.


    This bug fixes an EC2-style credentials invalidation issue
    in openstack-keystone. Only setups enabling EC2-style
    credentials are affected. CVE-2012-5571 has been assigned
    to this issue.

    Security Issue reference:

    * CVE-2012-5571

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Cloud 1.0:
      zypper in -t patch sleclo10sp2-openstack-keystone-7107

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Cloud 1.0 (x86_64):
    • openstack-keystone-2012.1+git.1353613280.c17a999-0.5.1
    • openstack-keystone-doc-2012.1+git.1353613280.c17a999-0.5.1
    • python-keystone-2012.1+git.1353613280.c17a999-0.5.1