Security update for Qt4

SUSE Security Update: Security update for Qt4
Announcement ID: SUSE-SU-2012:1428-1
Rating: moderate
References: #779952
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Linux Enterprise Server 11 SP2 for VMware
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP2

  • An update that fixes one vulnerability is now available.

    Description:


    libqt4 has been updated to fix the "CRIME" attack where
    compression using SSL connections have side-channel
    attacks to leak plaintext or cryptographic keys.

    Compression has been disabled to mitigate the CRIME attack
    (CVE-2012-4929).

    Security Issue reference:

    * CVE-2012-4929
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp2-libQtWebKit-devel-6935
    • SUSE Linux Enterprise Server 11 SP2 for VMware:
      zypper in -t patch slessp2-libQtWebKit-devel-6935
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp2-libQtWebKit-devel-6935
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp2-libQtWebKit-devel-6935

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • libQtWebKit-devel-4.6.3-5.18.1
    • libqt4-devel-4.6.3-5.18.1
    • libqt4-sql-postgresql-4.6.3-5.18.1
    • libqt4-sql-unixODBC-4.6.3-5.18.1
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (ppc64 s390x x86_64):
    • libQtWebKit4-32bit-4.6.3-5.18.1
    • libqt4-sql-mysql-32bit-4.6.3-5.18.1
    • libqt4-sql-postgresql-32bit-4.6.3-5.18.1
    • libqt4-sql-sqlite-32bit-4.6.3-5.18.1
    • libqt4-sql-unixODBC-32bit-4.6.3-5.18.1
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (noarch):
    • libqt4-devel-doc-data-4.6.3-5.18.1
    • SUSE Linux Enterprise Software Development Kit 11 SP2 (ia64):
    • libQtWebKit4-x86-4.6.3-5.18.1
    • libqt4-sql-mysql-x86-4.6.3-5.18.1
    • libqt4-sql-postgresql-x86-4.6.3-5.18.1
    • libqt4-sql-sqlite-x86-4.6.3-5.18.1
    • libqt4-sql-unixODBC-x86-4.6.3-5.18.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64):
    • libQtWebKit4-4.6.3-5.18.1
    • libqt4-4.6.3-5.18.1
    • libqt4-qt3support-4.6.3-5.18.1
    • libqt4-sql-4.6.3-5.18.1
    • libqt4-sql-mysql-4.6.3-5.18.1
    • libqt4-sql-sqlite-4.6.3-5.18.1
    • libqt4-x11-4.6.3-5.18.1
    • SUSE Linux Enterprise Server 11 SP2 for VMware (x86_64):
    • libQtWebKit4-32bit-4.6.3-5.18.1
    • libqt4-32bit-4.6.3-5.18.1
    • libqt4-qt3support-32bit-4.6.3-5.18.1
    • libqt4-sql-32bit-4.6.3-5.18.1
    • libqt4-x11-32bit-4.6.3-5.18.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • libQtWebKit4-4.6.3-5.18.1
    • libqt4-4.6.3-5.18.1
    • libqt4-qt3support-4.6.3-5.18.1
    • libqt4-sql-4.6.3-5.18.1
    • libqt4-sql-mysql-4.6.3-5.18.1
    • libqt4-sql-sqlite-4.6.3-5.18.1
    • libqt4-x11-4.6.3-5.18.1
    • SUSE Linux Enterprise Server 11 SP2 (ppc64 s390x x86_64):
    • libQtWebKit4-32bit-4.6.3-5.18.1
    • libqt4-32bit-4.6.3-5.18.1
    • libqt4-qt3support-32bit-4.6.3-5.18.1
    • libqt4-sql-32bit-4.6.3-5.18.1
    • libqt4-x11-32bit-4.6.3-5.18.1
    • SUSE Linux Enterprise Server 11 SP2 (ia64):
    • libQtWebKit4-x86-4.6.3-5.18.1
    • libqt4-qt3support-x86-4.6.3-5.18.1
    • libqt4-sql-x86-4.6.3-5.18.1
    • libqt4-x11-x86-4.6.3-5.18.1
    • libqt4-x86-4.6.3-5.18.1
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):
    • libQtWebKit4-4.6.3-5.18.1
    • libqt4-4.6.3-5.18.1
    • libqt4-qt3support-4.6.3-5.18.1
    • libqt4-sql-4.6.3-5.18.1
    • libqt4-sql-mysql-4.6.3-5.18.1
    • libqt4-sql-postgresql-4.6.3-5.18.1
    • libqt4-sql-sqlite-4.6.3-5.18.1
    • libqt4-sql-unixODBC-4.6.3-5.18.1
    • libqt4-x11-4.6.3-5.18.1
    • SUSE Linux Enterprise Desktop 11 SP2 (x86_64):
    • libQtWebKit4-32bit-4.6.3-5.18.1
    • libqt4-32bit-4.6.3-5.18.1
    • libqt4-qt3support-32bit-4.6.3-5.18.1
    • libqt4-sql-32bit-4.6.3-5.18.1
    • libqt4-sql-mysql-32bit-4.6.3-5.18.1
    • libqt4-sql-postgresql-32bit-4.6.3-5.18.1
    • libqt4-sql-sqlite-32bit-4.6.3-5.18.1
    • libqt4-sql-unixODBC-32bit-4.6.3-5.18.1
    • libqt4-x11-32bit-4.6.3-5.18.1

    References:

    • http://support.novell.com/security/cve/CVE-2012-4929.html
    • https://bugzilla.novell.com/779952
    • http://download.suse.com/patch/finder/?keywords=bb5ee44df67a64b7fc80a596cc675822