Security update for perl-DBD-Pg

SUSE Security Update: Security update for perl-DBD-Pg
Announcement ID: SUSE-SU-2012:0791-1
Rating: low
References: #751500
Affected Products:
  • SUSE Studio Standard Edition 1.2
  • SLE SDK 10 SP4

  • An update that fixes one vulnerability is now available.


    perl-DBD-Pg was prone to format string errors which could
    have crashed applications (CVE-2012-1151). This has been

    Security Issue references:

    * CVE-2012-1151

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Studio Standard Edition 1.2:
      zypper in -t patch sleslms12-perl-DBD-Pg-6019

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Studio Standard Edition 1.2 (x86_64):
    • perl-DBD-Pg-2.10.3-1.20.1
    • SLE SDK 10 SP4 (i586 ia64 ppc s390x x86_64):
    • perl-DBD-Pg-1.43-13.10.1