Recommended update for Hyper-V

SUSE Recommended Update: Recommended update for Hyper-V
Announcement ID: SUSE-RU-2012:1673-1
Rating: low
References: #676890 #761200 #790469 #791605
Affected Products:
  • SUSE Linux Enterprise Server 11 SP2

  • An update that solves two vulnerabilities and has two fixes is now available.


    This update to hyper-v adds support for KVP IP injection, a
    feature to set the clients IP address from the host.

    Additionally, two denial-of-service vulnerabilities
    (CVE-2012-2669, CVE-2012-5532) are fixed with this update
    and packaging has been improved.

    Security Issues:

    * CVE-2012-2669
    * CVE-2012-5532

    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp2-hyper-v-7106

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 11 SP2 (i586 x86_64):
    • hyper-v-4-0.9.1