Recommended update for multipath-tools

SUSE Recommended Update: Recommended update for multipath-tools
Announcement ID: SUSE-RU-2012:1482-1
Rating: low
References: #656036 #719838 #749577 #749584 #773407 #775623 #787217
Affected Products:
  • SUSE Linux Enterprise Server 10 SP4
  • SUSE Linux Enterprise Desktop 10 SP4

  • An update that has 7 recommended fixes can now be installed.


    This collective update to multipath-tools include the
    following fixes:

    * Set geometry information for multipath maps,
    preventing a floating point exception when installing the
    Grub boot loader (bnc#749577)
    * Initialize pointer passed to get_cmdvec, fixing a
    segmentation fault when invalid commands were entered in
    the interactive mode (bnc#773407)
    * Fix exit status for -h and -t options in multipath
    command (bnc#775623)
    * Add new SAN arrays from Intel and DataCore to
    hardware table (bnc#749584)
    * Rework sysfs device handling, fixing recovery
    problems with iSCSI paths (bnc#719838)
    * Remove caching of sysfs devices (bnc#656036)
    * Fix segmentation fault in multipath -t (bnc#787217).

    Package List:

    • SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):
    • multipath-tools-0.4.7-34.70.1
    • SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):
    • multipath-tools-0.4.7-34.70.1