Recommended update for openstack-keystone

SUSE Recommended Update: Recommended update for openstack-keystone
Announcement ID: SUSE-RU-2012:1358-1
Rating: low
References: #779747 #782289
Affected Products:
  • SUSE Cloud 1.0

  • An update that has two recommended fixes can now be installed.


    This update for openstack-keystone provides the following

    * Require authz to update user's tenant
    * List tokens for memcached backend
    * Delete user tokens after role grant/revoke
    * Remove superfluous editing of /usr/bin/gensslcert in
    postinstallation script (bnc#779747)
    * utf-8 encode user keys in memcache (bug 1056373)
    * make init script start after database
    * add --all_tenants option to volume-list command

    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Cloud 1.0:
      zypper in -t patch sleclo10sp2-openstack-keystone-201209-6912

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Cloud 1.0 (x86_64):
    • openstack-keystone-2012.1+git.1348675554.0e1f05e-0.5.1
    • openstack-keystone-doc-2012.1+git.1348675554.0e1f05e-0.5.1
    • python-keystone-2012.1+git.1348675554.0e1f05e-0.5.1
    • python-novaclient-2012.1+git.1345053935.bab694e-0.8.1