Recommended update for SUSE Manager Proxy

SUSE Recommended Update: Recommended update for SUSE Manager Proxy
Announcement ID: SUSE-RU-2012:0822-1
Rating: moderate
References: #759364 #760771 #764532 #765123
Affected Products:
  • SUSE Manager Proxy 1.2 for SLE 11 SP1

  • An update that has four recommended fixes can now be installed.


    This update fixes the following issues:

    * ignore ip6addr if provided with hw_refresh from newer
    client versions
    * do not add a bootstrap repository on SLES 11-SP2
    * fix AttributeError when connecting to proxy server.
    * fix ISE during registration because of duplicate ids
    * fix wrong transaction name in unsubscribe_channels
    * fix saving of SUSE Product names

    How to apply this update:

    1. Log in as root user to the SUSE Manager proxy. 2. Stop
    the proxy service: mgr-proxy stop 3. Apply the patch
    using either zypper patch or YaST Online Update. 4. Start
    the Spacewalk service: mgr-proxy start


    Everbody should update.

    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Manager Proxy 1.2 for SLE 11 SP1:
      zypper in -t patch slemap12sp1-spacewalk-backend-6444

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Manager Proxy 1.2 for SLE 11 SP1 (x86_64):
    • spacewalk-backend-1.2.74-0.58.1
    • spacewalk-backend-libs-1.2.74-0.58.1
    • SUSE Manager Proxy 1.2 for SLE 11 SP1 (noarch):
    • spacewalk-certs-tools-1.2.2-0.28.3
    • spacewalk-proxy-broker-1.2.15-0.15.12
    • spacewalk-proxy-common-1.2.15-0.15.12
    • spacewalk-proxy-management-1.2.15-0.15.12
    • spacewalk-proxy-package-manager-1.2.15-0.15.12
    • spacewalk-proxy-redirect-1.2.15-0.15.12