Recommended update for ghostscript

SUSE Recommended Update: Recommended update for ghostscript
Announcement ID: SUSE-RU-2012:0482-1
Rating: low
References: #635004 #649207 #726092
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP2
  • SUSE Linux Enterprise Software Development Kit 11 SP1
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Server 11 SP1 for VMware
  • SUSE Linux Enterprise Server 11 SP1
  • SUSE Linux Enterprise Desktop 11 SP2
  • SUSE Linux Enterprise Desktop 11 SP1

  • An update that solves two vulnerabilities and has one errata is now available.

    Description:


    This update for ghostscript-library fixes a regression in
    Ghostscript 8.62 where it did no longer use fonts
    specified via FONTPATH=/path/to/font when they are not
    considered to be resource fonts.

    In addition, the following low impact security fixes are
    included:

    * CVE-2009-3743: Off-by-one error in the TrueType
    bytecode interpreter in Ghostscript before 8.71 allowed
    remote attackers to cause a denial of service (heap memory
    corruption) via a malformed TrueType font in a document.
    * CVE-2010-4054: The gs_type2_interpret function in
    Ghostscript allowed remote attackers to cause a denial of
    service (incorrect pointer dereference and application
    crash) via crafted font data in a compressed data stream.

    Security Issue references:

    * CVE-2009-3743
    >
    * CVE-2010-4054
    >

    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP2:
      zypper in -t patch sdksp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Software Development Kit 11 SP1:
      zypper in -t patch sdksp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Server 11 SP2:
      zypper in -t patch slessp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Server 11 SP1 for VMware:
      zypper in -t patch slessp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Server 11 SP1:
      zypper in -t patch slessp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Desktop 11 SP2:
      zypper in -t patch sledsp1-ghostscript-devel-5916
    • SUSE Linux Enterprise Desktop 11 SP1:
      zypper in -t patch sledsp1-ghostscript-devel-5916

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • ghostscript-devel-8.62-32.32.1
    • ghostscript-ijs-devel-8.62-32.32.1
    • libgimpprint-devel-4.2.7-32.32.1
    • SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64 s390x x86_64):
    • ghostscript-devel-8.62-32.32.1
    • ghostscript-ijs-devel-8.62-32.32.1
    • libgimpprint-devel-4.2.7-32.32.1
    • SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):
    • ghostscript-fonts-other-8.62-32.32.1
    • ghostscript-fonts-rus-8.62-32.32.1
    • ghostscript-fonts-std-8.62-32.32.1
    • ghostscript-library-8.62-32.32.1
    • ghostscript-omni-8.62-32.32.1
    • ghostscript-x11-8.62-32.32.1
    • libgimpprint-4.2.7-32.32.1
    • SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):
    • ghostscript-fonts-other-8.62-32.32.1
    • ghostscript-fonts-rus-8.62-32.32.1
    • ghostscript-fonts-std-8.62-32.32.1
    • ghostscript-library-8.62-32.32.1
    • ghostscript-omni-8.62-32.32.1
    • ghostscript-x11-8.62-32.32.1
    • libgimpprint-4.2.7-32.32.1
    • SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):
    • ghostscript-fonts-other-8.62-32.32.1
    • ghostscript-fonts-rus-8.62-32.32.1
    • ghostscript-fonts-std-8.62-32.32.1
    • ghostscript-library-8.62-32.32.1
    • ghostscript-omni-8.62-32.32.1
    • ghostscript-x11-8.62-32.32.1
    • libgimpprint-4.2.7-32.32.1
    • SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):
    • ghostscript-fonts-other-8.62-32.32.1
    • ghostscript-fonts-rus-8.62-32.32.1
    • ghostscript-fonts-std-8.62-32.32.1
    • ghostscript-library-8.62-32.32.1
    • ghostscript-omni-8.62-32.32.1
    • ghostscript-x11-8.62-32.32.1
    • libgimpprint-4.2.7-32.32.1
    • SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):
    • ghostscript-fonts-other-8.62-32.32.1
    • ghostscript-fonts-rus-8.62-32.32.1
    • ghostscript-fonts-std-8.62-32.32.1
    • ghostscript-library-8.62-32.32.1
    • ghostscript-omni-8.62-32.32.1
    • ghostscript-x11-8.62-32.32.1
    • libgimpprint-4.2.7-32.32.1

    References:

    • http://support.novell.com/security/cve/CVE-2009-3743.html
    • http://support.novell.com/security/cve/CVE-2010-4054.html
    • https://bugzilla.novell.com/635004
    • https://bugzilla.novell.com/649207
    • https://bugzilla.novell.com/726092
    • http://download.suse.com/patch/finder/?keywords=d32438d017a666c248f87a90698dda0a