SUSE Support

Here When You Need Us

application core created on kernel 3.0.101-108.35 not readable

This document (7022975) is provided subject to the disclaimer at the end of this document.

Environment


SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
SUSE Linux Enterprise Server 11 for SAP Applications Service Pack 4

Situation

An application crashes and writes a core dump.
To analyze the issue the core file needs to opened in a debugger, but the core cannot be read easily.
gdb stops with: "Backtrace stopped: Cannot access memory at address 0x2b"

Example:
sles11sp4-lvm:~ # gdb ./core-108.35
GNU gdb (GDB; SUSE Linux Enterprise 11) 7.9.1
...
[New LWP 22994]
Reading symbols from /usr/bin/yes...Reading symbols from
/usr/lib/debug/usr/bin/yes.debug...done.
done.
Core was generated by `yes yes'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000000000000033 in ?? ()
(gdb) bt
#0  0x0000000000000033 in ?? ()
Backtrace stopped: Cannot access memory at address 0x2b
(gdb)


Resolution

This issue is fixed with a subsequently released kernel update.
Make sure to update the kernel to anything higher than  3.0.101-108.41.

Cause

This issue is caused by an incomplete fix for Spectre and Meltdown and only can occur with kernel 3.0.101-108.35.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022975
  • Creation Date: 17-May-2018
  • Modified Date:12-Oct-2022
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.