SUSE Support

Here When You Need Us

Reposync downloads all packages in the res7-x86_64 channel again

This document (000021376) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager
Subscription Management Tool (SMT 12)
SUSE Linux Enterprise Server 15 running Repository Management Tool (RMT 15)

Situation

A reposync scheduled after 10am on Feb. 27 downloaded all packages in channel res7-x86_64 again.
Due to the size of the repository, the filesystem storing the packages may have run out of space.

Resolution

The issue was fixed shortly after the incident, reposyncs after Feb. 27, 2024 - 15:00h CET should work as expected.
SUSE Support is working with engineering on a set of instructions how to restore the local repository to the old state, freeing occupied space again. See below, Section "Additional Information"

Cause

Due to an update in the infrastructure behind the SUSE Customer Center (SCC) all packages in the res7-x86_64 channel were re-signed, which led to SUMA/RMT/SMT recognizing them as new packages, which triggered the resync.
The repository was restored in the previous state and SUSE is working on a fix to prevent further incidents.

Status

Reported to Engineering

Additional Information

Cleaning up the superfluous packages can be done by running:

SMT :  
smt-mirror --clean 
RMT:     
rmt-cli clean packages

On SUMA it depends.
In case the sync finished without error, SUMA should delete the superfluous packages automatically.

If the sync was interrupted, the already downloaded packages can be deleted manually by:
find /var/spacewalk/packages/NULL/stage/ -type f | xargs rm 
Take extra care with that commandline, as the command deletes files without safety question!
Esp. a whitespace inbetween the search path /var/spacewalk/packages/NULL/stage/ can lead to data loss!
In doubt, run the command first without piping it's output through xargs and confirm nothing outside /var/spacewalk/packages/NULL/stage/ is listed.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021376
  • Creation Date: 29-Feb-2024
  • Modified Date:29-Feb-2024
    • Subscription Management Tool
    • SUSE Linux Enterprise Server
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.