SUSE Support

Here When You Need Us

mgr-sync-refresh results in error "No SUSE Manager Subscription available"

This document (000021337) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 4.3

Situation

When attempting to sync the products through Admin-Setup Wizard-Organization Credentials in the SUSE Manager Server webUI, the following error is returned:
2023-12-21 17:15:11,705 [ajp-nio-0:0:0:0:0:0:0:1-8009-exec-4] WARN com.redhat.rhn.manager.content.ContentSyncManager - No SUSE Manager Server Subscription available. Products requiring Client Tools Channel will not be shown.
The subscription and account credentials are valid, and the permissions on /etc/zypp/credentials.d/SCCcredentials are correct:
-rw-r----- 1 root www  122 Dec 22 00:29 /etc/zypp/credentials.d/SCCcredentials

Resolution

Increase the value of the parameter java.http_socket_timeout in /usr/share/rhn/config-defaults/rhn_java.conf, then restart the spacewalk service:

# spacewalk-service restart

This parameter can also be added to /etc/rhn/rhn.conf so that the value will remain persistent through OS updates.

Cause

SUSE Manager is unable to retrieve the SCC data due to a timeout when downloading the product tree from SCC.

Status

Reported to Engineering

Additional Information

Low bandwidth in the environment may also cause this issue.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021337
  • Creation Date: 29-Jan-2024
  • Modified Date:08-Feb-2024
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.