SUSE Support

Here When You Need Us

rmt-server-migration.service fails to start after update

This document (000021182) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server 15 SP4

Situation

After applying patches and checking the failed services.

The command "journalctl -xe" shows:
   A start job for unit rmt-server-migration.service has begun execution.
   
   The job identifier is 21314.
Aug 23 05:05:13 <servername> rails[10684]: rails aborted!
Aug 23 05:05:13 <servername> rails[10684]: NoMethodError: undefined method `username' for nil:NilClass
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/lib/rmt/config.rb:19:in `db_config'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/config/application.rb:42:in `database_configuration'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/app/models/application_record.rb:1:in `<top (required)>'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/app/models/activation.rb:1:in `<top (required)>'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/config/environment.rb:5:in `<top (required)>'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/Rakefile:6:in `require_relative'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/Rakefile:6:in `<top (required)>'
Aug 23 05:05:13 <servername> rails[10684]: /usr/share/rmt/bin/rails:9:in `<main>'
Aug 23 05:05:13 <servername> rails[10684]: (See full trace by running task with --trace)
Aug 23 05:05:13 <servername> rails[10684]: INFO: RMT version 2.14
Aug 23 05:05:13 <servername> systemd[1]: rmt-server-migration.service: Main process exited, code=exited, status=1/FAILURE

 

Checking the package is installed as defined it shows "U" for  "User ownership differs":

rpm -Vf /etc/rmt.conf
S.5..U.T.  c /etc/rmt.conf
 

 

Resolution

Correct the owner permission running following command:

chown _rmt:root /etc/rmt.conf

 

Cause

File owner has been changed unexpected

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021182
  • Creation Date: 23-Aug-2023
  • Modified Date:31-Aug-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.