SUSE Support

Here When You Need Us

SUSE Manager 4.3.6 tomcat fails to start after new setup

This document (000021103) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.3.6
SUSE Manager for Retail 4.3.6

Situation

Due to changes in how the tomcat service is configured in SUSE Manager 4.3.6 there is a scenario where, after installation of SUSE Manager 4.3.6, tomcat will fail to start.

Steps causing this situation include installing SUSE Manager without using update repositories, and updating to the latest version of SUMA after installation but before initial configuration using the SUSE Manager Setup module (yast2 susemanager_setup).

Resolution

1) Backup existing /etc/tomcat/server.xml:
cp /etc/tomcat/server.xml /etc/tomcat/server.xml.backup

  
2) Apply XSL template with correct configuration:
xsltproc /usr/share/spacewalk/setup/server.xml.xsl /etc/tomcat/server.xml.backup > /etc/tomcat/server.xml

  
3) Restart tomcat service:
spacewalk-service restart

Cause

Changes in the latest tomcat packages cause SUSE Manager 4.3.6 to fail during configuration/setup.

Status

Top Issue

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021103
  • Creation Date: 20-Jun-2023
  • Modified Date:20-Jun-2023
    • SUSE Manager for Retail
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.