SUSE Support

Here When You Need Us

dmesg shows "fail to get NUMA node for CPU"

This document (000021040) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP5 Beta
SUSE Linux Enterprise Server 15 SP4

Situation

dmesg output - "dmesg | grep -i fail" - shows:
Fail to get numa node for CPU:x bus:x dev:x fn:x

This can be seen for example, when memory node interleaving is enabled in the BIOS:
BIOS -> Memory Settings -> Node Interleaving: Enabled

Resolution

The message is harmless and has been observed on some systems for example when "memory node interleaving" is enabled in the BIOS.

Cause

The BIOS does not provide NUMA node information e.g in memory interleaving mode.
SLE15-SP4 and SLE15-SP5 kernel check for NUMA_NO_NODE, the kernel discovers NUMA_NO_NODE and prints the warning,

The warning message was introduced by the following upstream commit:
("aa2ddd24 platform/x86: ISST: Use numa node id for cpu pci dev mapping").

As long as this message appears with memory node interleaving enabled, it is harmless and expected.

Additional Information

To avoid it, the BIOS could report the devices as being on node 0 when it emulates a single node when interleaving.
However as long as it doesn't, this warning will be shown.

Also, potentially other OEM systems may fail to report the numa node even without interleaving enabled.
It is possible that before "Sapphire Rapids", the numa node is not defined for the Speed Select PCI device in some OEM systems.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021040
  • Creation Date: 11-Apr-2023
  • Modified Date:17-Apr-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.