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SUSEConnect error: EOFError: end of file reached

This document (000020719) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP3

Situation

Server does not have direct connection to the internet and therefore unable to update or to register.

Resolution

Set up a SOCKS proxy (and HTTP(S) to SOCKS proxy).

While curl and zypper can work with a SOCKS proxy directly SUSEConnect would need a HTTP(S) proxy in between.
 

Set up a socksSOCKS5 proxy connection via ssh:

ssh -vvv -4 -N -D 8001 root@<ip_of_server_with_internet_connection>

To configure proxy globally within an operating system:

/etc/sysconfig/proxy:
PROXY_ENABLED="yes"
HTTPS_PROXY="socks5h://localhost:8001"
 

Temporarily configure curl to use that proxy via curl:

curl -x socks5h://127.0.0.1:8001 http://www.suse.com/


Temporarily set HTTPS proxy for zypper:

export HTTPS_PROXY="socks5h://localhost:8001"


SUSEConnect currently does not support SOCKS proxy, so a local HTTP to SOCKS proxy would be needed. SUSEConnect on 15-SP3 and prior versions works only with http proxy.

There is no supported solution. An unsupported solution would be to use any HTTP to SOCKS proxy e.g. privoxy or python pproxy package or use socksify.


Please also refer to how to setup proxy manually:

https://www.suse.com/support/kb/doc/?id=000017441

Cause

When trying to register SUSEConnect shows following  error message:
SUSEConnect error: EOFError: end of file reached
When trying to refresh repositories:
Error code: Connection failed

 

 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020719
  • Creation Date: 10-Aug-2022
  • Modified Date:14-Sep-2022
    • SUSE Linux Enterprise Server

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