SUSE Support

Here When You Need Us

Rados Gateway logs lots of "debug" messages after upgrading to SES 7.x

This document (000020649) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 7.x

Situation

After upgrading to SES 7.x an administrator believes that there is an excessive amount of "debug" related logs for the Rados Gateway (RGW), for example messages similar to the below:
 
2022-05-02T11:07:05.686333+01:00 <client> conmon[6079]: debug
2022-05-02T11:07:05.683+0000 7f24e66e4700 1 ====== starting new request req=0x7f26704ee490 =====

Resolution

Decrease the default log level for the RGW, setting it to 0/5 instead either on the client level or globally. For example, to set a value for a specific RGW client:
 
ceph config set client.rgw.<name> debug_rgw 0/5

To set a value on the client level for all clients, this includes non RGW clients:
 
ceph config set client debug_rgw 0/5
 
To set a value globally:
 
ceph config set global debug_rgw 0/5

Cause

In some cases the default RGW log level of "1/5" may be considered to be too verbose.

Additional Information

What and how much to log (or not to log) is up to administrators and needs vary, adjust the log level as and when needed.
 
To note here is that default log level and amount of logging did not change between SES versions, the default before and after is 1/5. The current "debug" prefix however can be misleading with SES 7.x.
 
Specifically regarding the setting of log levels, this may be set on a "global", "client" or "client.<name>" level. Setting it on the "client" level means that all clients (not only the RGW) will apply it. However, since the setting is only relevant for RGW clients (with a Ceph cluster RGW daemons are also considered clients) it is not a problem. The same applies when values are set globally.

To quickly get an overview of the current settings in effect for a cluster run:
 
ceph config dump

Also see the "Identifying gateway issues " in the SES 7 online documentation.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020649
  • Creation Date: 03-May-2022
  • Modified Date:03-May-2022
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.