SUSE Support

Here When You Need Us

DeepSea stage 0 skips ceph updates

This document (000019940) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 6

Situation

Running stage 0 to update the SES cluster reports that the updates state is being skipped and no updates are installed on any of the cluster minions. An excerpt from the DeepSea log shows messages similar to the following:
 
2021-04-12 11:20:49,622 [INFO] deepsea.monitor: Started State step: [-1/160] name=ceph.updates() on=['ses_minion.ses']
2021-03-12 11:20:50,040 [INFO] deepsea.monitor: Finished State step: [-1/160] name=ceph.updates() in=ses_minion.ses success=True
2021-03-12 11:20:50,189 [INFO] deepsea.monitor: Skipping non started state step: [28/160] name=ceph.updates()

Resolution

In the "/etc/salt/minion" configuration file of the minions remove the following section then restart the minions:
 
use_superseded:
  - module.run

Cause

Since salt 2017 a new syntax was introduced for the module.run state that can be enabled with the "use_superseded" setting. The setting enables salt to use a new YAML type structure which is incompatible with DeepSea, since DeepSea uses the old syntax.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019940
  • Creation Date: 12-Apr-2021
  • Modified Date:12-Apr-2021
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.