Physical Volume is using an old PV header

This document (000019878) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP2

Situation

When running the pvs command the following warning is displayed: 
 
s15sp2:~ # pvs -o +pv_ext_vsn
  WARNING: PV /dev/sde1 in VG vgdata01 is using an old PV header, modify the VG to update.
  PV         VG          Fmt  Attr PSize   PFree    PExtVsn
  /dev/sde1  vgdata01 lvm2 a--  200.00m       0        0

Resolution

To fix the issue, kindly use vgck command to update the PV metadata header to version 2. For example: 
 
s15sp2:~ # vgck --updatemetadata vgdata01
  WARNING: PV /dev/sde1 in VG vgdata01 is using an old PV header, modify the VG to update.
  WARNING: updating PV header on /dev/sde1 for VG vgdata01.

s15sp2:~ # pvs -o +pv_ext_vsn
  PV         VG          Fmt  Attr PSize   PFree    PExtVsn
  /dev/sde1  vgdata01 lvm2 a--  200.00m       0        2

After running vgck the PExtVsn changed from 0 to 2. 
Note: In above example the vgdata01 VG was migrated from SLES 11 SP4 to SLES 15 SP2.
In SLES 12 SP4|5 LVM uses LVM2 metadata. In older versions LVM1 can be used. 
 

Cause

This warning is caused by lvm metadata with old extension header version.
The related pv was created by old lvm2, and newer lvm2 will output the warning.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019878
  • Creation Date: 27-Feb-2021
  • Modified Date:16-Mar-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center