SUSE Support

Here When You Need Us

Updating GCE fence agent to v4.6 breaks fencing

This document (000019875) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability 15-SP1, 15-SP2, 12-SP4 and 12-SP5
SUSE Linux Enterprise Server for SAP Applications 15-SP1, 15-SP2, 12-SP4 and 12-SP5
SUSE Manager 4.0 and 4.1

Situation

High-Availabilty is used and system is running on Google-cloud.
After updating the fence-agents package to version 4.6.0, the fencing resources are no longer started and failover is not possible anymore.

Resolution

SUSE engineering released a fixed fence-agents package in version 4.7.0.
Either a downgrade to fence-agents-4.4.0 or  an update (recommended) to fence-agents-4.7.0 will restore fencing functionality.

Cause

Failure was caused by a call with a missing argument (zone) which was introduced upstream into 4.6 by an incorrect patch.

Example:

# journalctl -f -u corocync -u pacemaker
[OUTPUT TRIMMED]
Jan 20 14:01:59 gce-node01 /fence_gce[16406]: Failed retrieving GCE zone. Please provide --zone option: get_zone() missing 1 required positional argument: 'instance'
Jan 20 14:01:59 gce-node01 /fence_gce[16406]: Please use '-h' for usage
[OUTPUT TRIMMED]
"""

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019875
  • Creation Date: 17-Feb-2021
  • Modified Date:17-Feb-2021
    • SUSE Linux Enterprise High Availability Extension
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.