SUSE Support

Here When You Need Us

Node FQDNs and Aliases Don't Resolve on Admin Node and Barclamps cannot be Applied

This document (000019852) is provided subject to the disclaimer at the end of this document.

Environment

Suse Open stack Cloud 9 crowbar.
 

Situation

When node FQDNs and Aliases don't Resolve on the Admin Node, Barclamps cannot be Applied

Resolution

The problem here is that crowbar shouldn't add the forwarder to dnsmasq.conf (the forwarder goes to named.conf), but rather only IP addresses that are listed under "Additional name servers" in the DNS barclamp GUI.

After removal of the entries in the "Additional name servers" field in the DNS barclamp, the issue seems to have gone away.

Cause

Dnsmasq on localhost responds with a NXDOMAIN to a request containing local address query..
We discovered that crowbar was adding two separate entries in dnsmasq.conf: two duplicates for the local and another for the forwarder (which was set by customer in the barclamp), while keeping localhost as the first entry in resolve.conf

Because of the way dnsmasq treats dns servers listed in its config file, NXDOMAIN response is probably due to dnsmasq occasionally querying the wrong server from its list, which then, of course, gets responded with a NXDOMAIN message.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019852
  • Creation Date: 29-Jan-2021
  • Modified Date:16-Feb-2021
    • SUSE Open Stack Cloud

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.