SUSE Support

Here When You Need Us

IPMI driver can be unloaded when being accessed by user space

This document (000019602) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 Support Pack 1

Situation

The ipmi_si driver can be unloaded when /dev/ipmi is opened by user space utilities.

On Dell EMC PowerEdge systems with SLES 15 SP1 installed, this could lead to side effects such as the following message below being logged in iDRAC System Event Log when iSM (iDRAC Service Module) is running.

iSM uses /dev/ipmi device to communicate with iDRAC and the communication may break if ipmi_si driver is unloaded and following message is logged. 
The watchdog timer expired

 

Resolution

The issue is addressed in the following upstream commit :

ipmi: Don't allow device module unload when in use
https://github.com/torvalds/linux/commit/cbb79863fc3175ed5ac506465948b02a893a8235

This is resolved in SUSE Linux Enterprise Server 15 SP1 Maintenance Update Kernel version 4.12.14-197.34.1 and later  (04 Mar 2020 - the Linux Kernel 560)

Cause

Currently, it is possible to unload the driver when in use.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019602
  • Creation Date: 06-Apr-2020
  • Modified Date:06-Apr-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.