group with large number of users won't show anymore

This document (7016865) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)

Situation

A group which consists of a large number of users, to the point that the line in the /etc/group file is more than 580 characters is no longer effective.
Also file permissions will be affected and user cannot access files which depend upon that group membership.
If the size of the group line is decreased (e.g. removing user) and is less than 580 characters, the problem doesn't exist.

id <username> will show every group the user is member of, except the one with >580 characters (a large number of members or a large username in the group exceeding 580 characters).

Resolution

The glibc update to glibc-2.11.3-17.90.4 released October 2015 includes the patch to resolve this problem. Please install the recommended update.

Cause

If the entry is too large, nss_files getent returns unsuccessful and doesn't reread the entry.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7016865
  • Creation Date: 24-Sep-2015
  • Modified Date:14-Oct-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center