Package hub missing dependencies in SLES/SLED 15 SP1

This document (7024235) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Desktop

Situation

Installation of most of the SLES/SLED 15 SP1 Package Hub Packages fail due to its dependency packages missing.

Example of few packages:
/usr/bin/jpegtran needed by jhead-3.00-bp151.4.1.x86_64 is nowhere provided
WindowMaker requires WindowMaker-themes-0.1-bp151.374.1.norg will be provided nowhere
ffmpeg required by audacity-2.2.2-bp151.3.2.x86_64 is nowhere provided
gromacs = 2018.4-bp151.2.1 Required by gromacs-bash-2018.4-bp151.2.1.Norway nowhere provided lame required from k3b-18.12.3-bp151.2.1.x86_64 are nowhere provided libAppStreamQt.so.2 () (64bit) needed from framework integration-plugin-5.55.0-bp151.1.5.x86_64 is nowhere provided



Resolution

The Package Hub team is still working to fix this issue, and is addressing the dependency problems one by one.

Cause

The various Package Hub repositories were enabled without sufficiently checking all dependencies

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024235
  • Creation Date: 04-Nov-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center