My Favorites

Close

Please to see your favorites.

  • Bookmark
  • Email Document
  • Printer Friendly
  • Favorite
  • Rating:

aws-cli throwing Error on fresh SLES 15 Installation in AWS Cloud

This document (7023686) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15

Situation

On a fresh SLES 15 installation, which applies as well to SLES4SAP 15, there might be an issue that the aws-cli does not work as expected. This can be checked either by controlling the aws-cli version which should be

   1.16.61-4.7.1
   
or higher.

Or empirical by issuing the command

rumpelstielzchen:~ # aws

Traceback (most recent call last):

  File "/usr/bin/aws", line 19, in <module>

    import awscli.clidriver

  File "/usr/lib/python3.6/site-packages/awscli/clidriver.py", line 35, in <module>


the above shows the error in case of a not properly working aws-cli


This can render a Cluster Setup useless, as the HA Cluster Resource Agents depend on the aws-cli.
It is mandatory to fix this issue on a HA Cluster in an AWS Cloud Enviroment.

Resolution

The reason for this is an old package that was installed

rumpelstielzchen:~ # zypper info aws-cli

[...]

Information for package aws-cli:
--------------------------------
Repository     : @System
Name           : aws-cli
Version        : 1.11.185-2.20
Arch           : noarch
Vendor         : SUSE LLC <https://www.suse.com/>

Unfortunately the necessary update is not available in the default repositories

The "SUSE Cloud Application Platform Tools Module 15" has to be enabled in order to receive updates for the necessary package.

rumpelstielzchen:~ #SUSEConnect -p sle-module-public-cloud/15/x86_64

This repository is available without additional subscriptions or registration. It is free to use with any SLE 15 subscription)


After running

   zypper patch

the necessary update is detected. After installation of the update

rumpelstielzchen:~ # zypper info aws-cli

[...]

Information for package aws-cli:
--------------------------------
Repository     : SLE-Module-Public-Cloud15-Updates
Name           : aws-cli
Version        : 1.16.61-4.7.1
Arch           : noarch
Vendor         : SUSE LLC <https://www.suse.com/>
Support Level  : Level 3


aws-cli will work as expected.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023686
  • Creation Date:29-JAN-19
  • Modified Date:29-JAN-19
    • NovellSUSE Linux Enterprise Server for SAP Applications
    • SUSESUSE Linux Enterprise Server
< Back to Support Search

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center