SUSE Support

Here When You Need Us

pvmove hangs on 2T devices

This document (7016272) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11

Situation

When trying to move PEs from one 2T (or greater) multipathed device to another one that was just added to the volume group in a clustered environment will result in a hang with the following messages:

[ 6778.164097] device-mapper: dm-log-userspace: [autyCORE] Request timed out: [5/586] - retrying

Feb  3 08:48:17 hostname cmirrord[11391]: Sync checkpoint section create retry

Devices less than 2Tb work correctly.

Resolution

A bug fix has been created and will be released into the maintenance channel.  For now the workaround (also what the fix upstream does) is to
Modify the region_size of /etc/lvm/lvm.conf:
    raid_region_size = 512
==> raid_region_size = 2048

Cause

In a clustered environment, `pvmove` will create a temporary mirrored LV to sync data. Bitmap size is 256KB(due to message length limited at 1M), region_size(data region size of 1 bit in bitmap) is 512KB by default.
So if we use default region_size the volume size is limited at:
   512KB * 256KB*8 = 1TB

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7016272
  • Creation Date: 09-Mar-2015
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.