My Favorites

Close

Please to see your favorites.

  • Bookmark
  • Email Document
  • Printer Friendly
  • Favorite
  • Rating:

SLES9: heartbeat package cannot be uninstalled

This document (3149702) is provided subject to the disclaimer at the end of this document.

Environment


Novell SUSE Linux Enterprise Server 9 and Service Packs

Situation

Heartbeat package won't uninstall. YaST and rpm refuse to do so:

# rpm -e heartbeat
..unused
error: %preun(heartbeat-1.2.5-0.3) scriptlet failed, exit status 6

Reason is a missing check in the heartbeat initscript.

Resolution

Suppress the execution of the package's pre-uninstall script. The package can be  uninstalled with:

rpm -e --noscripts heartbeat

Additional Information

This applies to all heartbeat packages including the ones provided by SLES9 SP4.
It only happens if /etc/ha.d/ha.cf does not exist.


Change Log

2010/04/12 mkrapp Removed "Reported to Engineering", Document reworked

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:3149702
  • Creation Date:27-NOV-07
  • Modified Date:27-APR-12
    • SUSESUSE Linux Enterprise Server

Did this document solve your problem? Provide Feedback

< Back to Support Search

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center