SUSE Support

Here When You Need Us

Kiwi-Image does not boot with lvm root volume

This document (000021897) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15


Situation

A new image was build with kiwi-ng using Custom Disk Volumes and LVM like described in: 
https://osinside.github.io/kiwi/working_with_images/custom_volumes.html 

<systemdisk name="vgsystem" preferlvm="true"> 
    <volume name="@root" freespace="5G"/> 
    .. additional volume declarations .. 
</systemdisk> 
<size unit="G">15</size> 

The image build works correctly and it can be started. However the activation of the root logical volume never finishes:

"A start job is running for /dev/mapper/vgsystem-LVRoot (wait time / no limit)"

Resolution

Please edit the Kiwi configuration file and remove the next line:

<package name="combustion >= 1.2"/>

Cause

combustion should only be used with MicroOS for first boot configuration. For SLE, jeos-firstboot should be used instead.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021897
  • Creation Date: 01-Jul-2025
  • Modified Date:01-Jul-2025
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.