SUSE Support

Here When You Need Us

Cannot register new minions into SUSE Manager because of error A different object with the same identifier value ....

This document (000020993) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 4.3 Server
SUSE Manager 4.2 Server

Situation

Lately the SUSE Manager server has been registered as a minion to itself.

Fully working environment of SUSE Manager suddenly cannot register any new minions, and the error always is the same in
/var/log/rhn/rhn_web_ui.log
and looks like this at every attempt to register a new minion :
ERROR com.suse.manager.reactor.messaging.RegisterMinionEventMessageAction - Error registering minion id: *MINION*
org.hibernate.NonUniqueObjectException: A different object with the same identifier value was already associated with the session : [com.redhat.rhn.domain.server.ServerPath#com.redhat.rhn.domain.server.ServerPathId@12345678[server=com.redhat.rhn.domain.server.MinionServer@9876543[id=1000010004,org=com.redhat.rhn.domain.org.Org@3456789[id=1,name=*ORG*],name=*MINION*,description=<null>,machineId=1234567890abcdef0987654321fedcba,minionId=*MINION*],proxyServer=com.redhat.rhn.domain.server.MinionServer@87654321[id=1000010002,org=com.redhat.rhn.domain.org.Org@12345678[id=1,name=*ORG*],name=*MASTER*,description=<null>,machineId=0987654321fedcba1234567890abcdef,minionId=*MASTER*]]]

Resolution

From the SUSE Manager server webGUI, find and delete the SUSE Manager minion, and then new minions will register again without error.

Cause

Registering the SUSE Manager server as a minion to itself is not supported.  The registration of the SUSE Manager server as a minion to itself will work, but break registration of new minions.:


 

Additional Information

https://documentation.suse.com/suma/4.3/en/suse-manager/client-configuration/registration-webui.html
  Do not register the SUSE Manager Server to itself. The SUSE Manager Server must be managed individually

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020993
  • Creation Date: 28-Feb-2023
  • Modified Date:20-Mar-2023
    • SUSE Manager for Retail
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.