SUSE Support

Here When You Need Us

Upgrade client server from Sles15sp3 to Sles15sp4 via SUMA product migration

This document (000020796) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager: 4.2
 

Situation

Upgrade client-server from Sles15sp3 server to Sles15sp4 via product migration. Getting error message as below:
There is no migration available for this system. For some of the installed extensions, no successor could be found

Installed Sles15sp3 repositories list:
Public Cloud Module 15 SP3 x86_64
Legacy Module 15 SP3 x86_64
Containers Module 15 SP3 x86_64
SUSE Package Hub 15 SP3 x86_64
SUSE Manager Client Tools for SLE 15 x86_64
Python 2 Module 15 SP3 x86_64
Server Applications Module 15 SP3 x86_64
Basesystem Module 15 SP3 x86_64
Web and Scripting Module 15 SP3 x86_64
Development Tools Module 15 SP3 x86_64
Desktop Applications Module 15 SP3 x86_64

Resolution

As the client-server bootstrap against SUSE Manager, it is not possible to disable the python module with the SUSEConnect command:
# SUSEConnect -d -p sle-module-python2/15.3/x86_64

You can remove it manually with the zypper command:
# zypper rm sle-module-python2-release

Cause

In SLE 15 SP4, sle-module-python2 is no longer available. This means that migration (using yast2 migration or zypper migration) will not work without deactivating the python2 module first. 

Additional Information

The alternative way will be upgrading SUSE Manager to version 4.3.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020796
  • Creation Date: 03-Oct-2022
  • Modified Date:14-Oct-2022
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.