SUSE Support

Here When You Need Us

"nvme list" prints "Failed to open" hostnqn and hostid sysfs files

This document (000020676) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server 15 SP3

Situation

"nvme list" prints an error message before listing the NVMe drives:
 
# nvme list
Failed to open /sys/class/nvme-subsystem/nvme-subsys0/nvme0/hostnqn: No such file or directory
Failed to open /sys/class/nvme-subsystem/nvme-subsys0/nvme0/hostid: No such file or directory
Failed to open /sys/class/nvme-subsystem/nvme-subsys1/nvme1/hostnqn: No such file or directory
Failed to open /sys/class/nvme-subsystem/nvme-subsys1/nvme1/hostid: No such file or directory

Resolution

The SLES15 SP3 nvme-cli update released July 2022 includes the patch.

For SLES15 SP4 the error is scheduled to be fixed in a future maintenance update.
Customers affected by this issue can alternatively contact SUSE Technical Support to request a PTF (temporary fix).
 

Cause

The error is cosmetic (non critical) without any impact on the command's functionality.
The error messages can be ignored.
 

Status

Reported to Engineering

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020676
  • Creation Date: 21-Jun-2022
  • Modified Date:26-Jul-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.