SAP HANA monitors timed out after 5 seconds

This document (000020626) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise for SAP Applications 12
SUSE Linux Enterprise for SAP Applications 15

Situation

In certain situations on an SAPHanaSR scale-up system replication cluster the resource agent´s check about "hana system replication is in sync or not" times out and results in following:

a) Attribute hana_<SID>_sync_state to become "SFAIL"

b) message logged similar to:
...
2021-02-18T23:41:28.064098+00:00 hanadb2 SAPHana(rsc_SAPHana_HN1_HDB03)[10598]: WARNING: HANA_CALL timed out after 5 seconds running command 'systemReplicationStatus.py --site=S3'
...

 

Resolution

For database version HANA 1.0:
No resolution available for the scale-up package SAPHanaSR.
The SAPHanaSR.py included there does not work with HANA 1.0.
Besides that HANA 1.0 is end of regular support.


For database version HANA 2.0:
Implement srHook as defined.

For SLES for SAP 12:
https://documentation.suse.com/sbp/all/html/SLES4SAP-hana-sr-guide-PerfOpt-12/index.html#_implementing_the_python_hook_saphanasr

For SLES for SAP 15:
https://documentation.suse.com/sbp/all/html/SLES4SAP-hana-sr-guide-PerfOpt-15/index.html#id-set-up-sap-hana-hadr-providers

Cause

The issue is caused by a low timeout value of check of status of HANA system replication as defined in the SAPHana resource agent. This timeout definition is required for backward compatibility purpose. Cluster relies on this value to show the status of sync  between primary and secondary HANA. If it fails because of timeout, it gives a wrong impression that sync has failed which may not be the case. srHook implementation ensures that cluster now does not rely on sync_state value and instead it gets the status of  sync from srHook attributes.

Additional Information

See also:

Manual page SAPHanaSR.py(7), SAPHanaSR-swhowAttr(8).
https://www.suse.com/de-de/support/kb/doc/?id=000019754
https://www.suse.com/de-de/support/kb/doc/?id=000019865
 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020626
  • Creation Date: 29-Mar-2022
  • Modified Date:31-Mar-2022
    • SUSE Linux Enterprise Server for SAP Applications

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