Migration of SUSE Manager 3.0 from SLES 12 SP2 to SLES 12 SP3 fails: dependency error

This document (7023048) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 3

Situation

SLES 12 SP2 is out of support as of April 30th, 2018. However, SUSE Manager 3.0 is still supported (till late 2018). As a result, a migration to SP3 is expected in order to get support.

As a first step, in case it had not been carried out before, a migration of postgresql should be performed. Even after doing that, an error will be displayed when running "zypper migration" and selecting the option to only migrate the underlaying OS (SLES 12 SP2 to SLES 12 SP3):

vm-calzone:~ # zypper migration

Executing 'zypper  refresh'

Repository 'SLES12-SP2-Pool' is up to date.                                                                                           
Repository 'SLES12-SP2-Updates' is up to date.                                                                                        
Repository 'SUSE-Manager-Server-3.0-Pool' is up to date.                                                                              
Repository 'SUSE-Manager-Server-3.0-Updates' is up to date.                                                                           
All repositories have been refreshed.

Executing 'zypper  --no-refresh patch-check --updatestack-only'

Loading repository data...
Reading installed packages...

0 patches needed (0 security patches)

Available migrations:

    1 | SUSE Linux Enterprise High Performance Computing 12 SP3 x86_64
        SUSE Manager Server 3.1 x86_64
      
    2 | SUSE Linux Enterprise Server 12 SP3 x86_64
        SUSE Manager Server 3.1 x86_64
      
    3 | SUSE Linux Enterprise High Performance Computing 12 SP3 x86_64
        SUSE Manager Server 3.0 x86_64 (already installed)
      
    4 | SUSE Linux Enterprise Server 12 SP3 x86_64
        SUSE Manager Server 3.0 x86_64 (already installed)
      
    5 | SUSE Manager Server 3.1 x86_64
        SUSE Linux Enterprise Server 12 SP2 x86_64 (already installed)
      

[num/q]: 4

Executing 'snapper create --type pre --cleanup-algorithm=number --print-number --userdata important=yes --description 'before online migration''

Upgrading product SUSE Linux Enterprise Server 12 SP3 x86_64.
Upgrading product SUSE Manager Server 3.0 x86_64.

Executing 'zypper --releasever 12.3 ref -f'

Warning: Enforced setting: $releasever=12.3
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Pool' metadata ................................................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Pool' cache .....................................................................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP3-Updates' metadata .............................................................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP3-Updates' cache ..................................................................................[done]
Forcing raw metadata refresh
Retrieving repository 'SUSE-Manager-Server-3.0-Pool' metadata ...................................................................[done]
Forcing building of repository cache
Building repository 'SUSE-Manager-Server-3.0-Pool' cache ........................................................................[done]
Forcing raw metadata refresh
Retrieving repository 'SUSE-Manager-Server-3.0-Updates' metadata ................................................................[done]
Forcing building of repository cache
Building repository 'SUSE-Manager-Server-3.0-Updates' cache .....................................................................[done]
All repositories have been refreshed.

Executing 'zypper --releasever 12.3  --no-refresh  dist-upgrade --no-allow-vendor-change '

Warning: Enforced setting: $releasever=12.3
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: nothing provides product(SLES) = 12.1 needed by product:SUSE-Manager-Server-3.0-0.x86_64
Problem: nothing provides product(SLES) = 12.1 needed by product:SUSE-Manager-Server-3.0-0.x86_64

Problem: nothing provides product(SLES) = 12.1 needed by product:SUSE-Manager-Server-3.0-0.x86_64
 Solution 1: Following actions will be done:
  deinstallation of product:SUSE-Manager-Server-3.0-0.x86_64
  deinstallation of patterns-suma_server-3.0-6.1.x86_64
 Solution 2: keep obsolete product:SLES-12.2-0.x86_64
 Solution 3: break SUSE-Manager-Server-release-3.0-1.21.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):

Resolution

There was a wrong dependency in the release package. The fix is already part of the repositories, and the error should not be displayed any more. Should that still be the case, please refresh your repositories and try again.

Cause

A wrong dependency in the release package. It needed to be fixed through a maintenance update.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023048
  • Creation Date: 05-Jun-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center