SUSE Support

Here When You Need Us

/var/log/salt/master prints warnings about raising max open soft setting

This document (7023016) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager release 3.1.5

10000 minions registered
5 SUSE Manager Proxies with about 2000 minions connected each.

Situation

After 10000 minion registrations on SUSE Manager, this message starts to appear in /var/log/salt/master:

May 16 21:00:44 SUMA salt-master[9735]: [WARNING ] The number of accepted minion keys(6392) should be lower than 1/4 of the max open files soft setting(16384). Please consider raising this value.

Resolution

In this specific case, it is cosmetic and can be ignored. Proxies are correctly configured for 10000 minions. Please see for details https://www.suse.com/documentation/suse-manager-3/book_suma_advanced_topics_31/data/optimizing_big.html.

Proxies reduce the number of TCP connections, as the ZeroMQ connections are multiplexed. So the warning would still be there (as Salt assumes the number of required TCP connections to be twice the number of keys, because each minion can use up to two ZeroMQ connections consuming one TCP connection each), but it would be harmless.

To verify the number of TCP connections taken on each proxies and the SUSE Manager master, please run:

neststat -a |grep -e "450[5,6]"|grep ESTABLISHED|wc -l

If no minions are connected directly to the SUSE Manager master, it should get one per Proxy connections in total, which can become two per Proxy during times of activity (not taking non-Salt specific connections into account though).

Cause


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023016
  • Creation Date: 25-May-2018
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.