SUSE Support

Here When You Need Us

How to configure "external" network in network.json

This document (7022474) is provided subject to the disclaimer at the end of this document.

Environment

SUSE OpenStack Cloud 7

Situation

There are two separate networks, each on a dedicated switch. First network is for SUSE OpenStack Cloud 7 traffic, the second is for accessing iscsi storage resources.

The requirement is to have an "external" network for pacemaker sbd device, rabbitmq and database shared storage.

Resolution

Define an "external" network in network.json according to "Custom Network Configuration, Providing Access to External Networks" chapter in SUSE OpenStack Cloud 7 Deployment Guide.

           "external" : {
               "add_bridge" : false,
               "vlan" : XXX,
               "ranges" : {
                  "host" : {
                     "start" : "192.168.150.1",
                     "end" : "192.168.150.254"
                  }
               },
               "broadcast" : "192.168.150.255",
               "netmask" : "255.255.255.0",
               "conduit" : "intf1",
               "subnet" : "192.168.150.0",
               "use_vlan" : true
            }

           
To have this "external" network before configuring barclamps use 'crowbarctl' command for a particular node.

On admin node:
#crowbarctl network interface enable default d52-54-00-63-a1-01.example.com external
#crowbarctl network hostip allocate default d52-54-00-63-a1-01.example.com external host

Then on d52-54-00-63-a1-01.example.com:
#systemctl restart chef-client.service

Afterwards configure iscsi initiator on the nodes. Deploy pacemaker, rabbitmq and database barclamps.

Cause

Many external networks can be defined. Crowbar must be aware of them, have an interface enabled in the external network with an ip address allocated.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022474
  • Creation Date: 19-Dec-2017
  • Modified Date:03-Mar-2020
    • SUSE Open Stack Cloud

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.