zypper migration with LTSS repo results in "No migration available"

This document (7022381) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15 (SLE15)
SUSE Linux Enterprise Server 15 LTSS (Long Term Service Pack Support)
SUSE Linux Enterprise Server 12 Service Pack 5 (SLES 12 SP5)
SUSE Linux Enterprise Server 12 Service Pack 4 (SLES 12 SP4)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 (SLE12)
SUSE Linux Enterprise Desktop 12 (SLE12)
SUSE Linux Enterprise Server 12 LTSS (Long Term Service Pack Support)

Situation

When a server is registered to SCC (SUSE Customer Center) or SMT (Subscription Management Tool) with LTSS (Long Term Service Pack Support) repositories enabled and the "zypper migration" command is issued, the result is "No migration available":
 
# zypper migration
Executing 'zypper refresh'
Repository 'SLES12-SP2-LTSS-Updates' is up to date.
Repository 'SLES12-SP2-Pool' is up to date.
Repository 'SLES12-SP2-Updates' is up to date.
All repositories have been refreshed.

Executing 'zypper --no-refresh patch-check --updatestack-only'

Loading repository data...
Reading installed packages...
0 patches needed (0 security patches)

No migration available.

Resolution

The LTSS repositories must be removed before the migration in order for the migration to be successful.  To get information on the current extensions:
 
# SUSEConnect --list-extensions
AVAILABLE EXTENSIONS AND MODULES

    Advanced Systems Management Module 12 x86_64
    Activate with: SUSEConnect    -p sle-module-adv-systems-management/12/x86_64

    SUSE Linux Enterprise Server LTSS 12 SP2 x86_64 (Installed)
    Deactivate with: SUSEConnect -d -p SLES-LTSS/12.2/x86_64

MORE INFORMATION

You can find more information about available modules here:
https://www.suse.com/products/server/features/modules.html
 
To remove any LTSS repositories, using the above example take the following steps:
 
# SUSEConnect -d -p SLES-LTSS/12.2/x86_64
# zypper ref -s

Verify the LTSS repository is not present anymore:
 
# zypper lr
# | Alias | Name | Enabled | GPG Check | Refresh
--+-------------------------------------------+--------------------+---------+-----------+--------
1 | SMT-http_sles12s2_suse:SLES12-SP2-Pool | SLES12-SP2-Pool | Yes | (r ) Yes | No
2 | SMT-http_sles12s2_suse:SLES12-SP2-Updates | SLES12-SP2-Updates | Yes | (r ) Yes | Yes

Now the migration to SLES12-SP2/SP3 is available:
 
# zypper migration
Executing 'zypper refresh'

Repository 'SLES12-SP2-Pool' is up to date.
Repository 'SLES12-SP2-Updates' is up to date.
All repositories have been refreshed.

Executing 'zypper --no-refresh patch-check --updatestack-only'

Loading repository data...
Reading installed packages...
0 patches needed (0 security patches)
Available migrations:

1 | SUSE Linux Enterprise Server 12 SP4 x86_64

2 | SUSE Linux Enterprise Server 12 SP3 x86_64

[num/q]:

Cause

"Available migrations" only lists targets where a system can be migrated to including all installed extensions.

This is an issue for systems with LTSS, because the LTSS extension is not yet available for the migration target product and because of the special setup of LTSS subscriptions, they are version-bound.

 

Additional Information

SLES12-GA with LTSS might show an available migration path to SLES12-SP1/SP2/SP3 with LTSS.
Similarly, from SLES12-SP2 with LTSS there are available migration paths only to SP3/SP4 LTSS.
However, from SLES12-SP3/SP4 with LTSS there are no available migrations paths to SP5.
Removing the LTSS repository from SLES12-GA will allow migration directly to SLES12-SP2/SP3 (not to SP4 because it is not possible to skip more than one SP).

For additional LTSS info see:
https://www.suse.com/products/long-term-service-pack-support/
https://www.suse.com/lifecycle/
https://www.suse.com/support/policy/

For the same problem in a SUSE Manager environment, please see:
https://www.suse.com/support/kb/doc/?id=000019827

In SLES15 changes to zypper were made to notify which repository should be removed:
All repositories have been refreshed.
Can't get available migrations from server: SUSE::Connect::ApiError: There are activated extensions/modules on this system which cannot be migrated.
De-activate them first, and then try migrating again.
The product(s) are 'SUSE Linux Enterprise Server LTSS 15 SP1 x86_64'.
You can de-activate them with:
SUSEConnect -d -p SLES-LTSS/15.1/x86_64
'/usr/lib/zypper/commands/zypper-migration' exited with status 1

 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7022381
  • Creation Date: 28-Nov-2017
  • Modified Date:23-Nov-2021
    • Subscription Management Tool
    • SUSE Linux Enterprise Desktop
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center