SMT Client error during registration: Your Registration Proxy server doesn't support this function

This document (7018261) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)

Situation

When registering a new SLES12 SP2 SMT Client machine to an existing SMT Server with the "clientSetup4SMT.sh" script, the following logs are shown:

# ./clientSetup4SMT.sh https://smtserverhost/center/regsvc
Do you accept this certificate? [y/n] y
Client setup finished.
Start the registration now? [y/n] y
/usr/bin/SUSEConnect --write-config --url
https://smtserverhost/center/regsvc
Your Registration Proxy server doesn't support this function. Please update it and try again.


When the debug log for SUSEConnect is enabled, the following logs are seen:
# /usr/bin/SUSEConnect --debug --write-config --url https://smtserverhost/center/regsvc
.....
-> "{\"localized_error\":\"No repositories found\",\"status\":422,\"type\":\"error\",\"error\":\"No repositories found\"}"
....
-> "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<html><head>\n<title>404 Not Found</title>\n</head><body>\n<h1>Not Found</h1>\n<p>The requested URL /connect/repositories/installer was not found on this server.</p>\n<p>Additionally, a 404 Not Found\nerror was encountered while trying to use an ErrorDocument to handle the request.</p>\n</body></html>\n"

Resolution

Ensure the SMT Server has enabled and mirrored all the necessary SLES12 SP2 Repositories (e.g. SLES12-SP2-Pool, SLES12-SP2-Updates):

  1. Navigate to YaST ->  "Network Services" -> "SMT Server Management" GUI Wizard.

  2. Select and enable the necessary SLES12 SP2 related Repositories.

  3. Start the SMT mirror operation.

After the SMT mirror operation has completed, the SUSEConnect command should be able to register the SMT Client machine successfully.

Cause

The SMT Server has not enabled and mirrored the necessary SLES12 SP2 Repositories.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018261
  • Creation Date: 11-Nov-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center