Service Pack migration on SLES fails with internal SMT registered against SCC

This document (7016008) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 11

Situation

While trying to perform a Service Pack migration using an internal SMT (Subscription Management Tool) that is registered against SCC (SUSE Customer Center) the following error message is received:
ERROR: 400: Product (SUSE_SLES-SP3-migration 11.2 x86_64) not found on Server.400 Bad Request

Resolution

A bug has been filed for this.

 

Cause

The issue is caused by SCC delivering the wrong version numbers for the migration products.

On the SMT run "smt-list-products" to get an overview of all existing products (this includes the migration products).

For a migration from SLES 11 SP2 to SP3 on x86_64 as an example, the following output it generated:
smt-list-products
.-----------------------------------------------------------------------------------------------------.
| ID     | Name                                     | Version | Architecture | Release        | Usage |
+--------+------------------------------------------+---------+--------------+----------------+-------+
| 100565 | SUSE_SLES-SP3-migration                  |    11.3 | x86_64       | -              |     - |

So the "Version" is shown as "11.3". But it should be "11.2".

This can be tested on a SMT server still pointing to NCC (Novell Customer Center (*)):
smt-list-products
.-----------------------------------------------------------------------------------------------------.
| ID     | Name                                     | Version | Architecture | Release        | Usage |
+--------+------------------------------------------+---------+--------------+----------------+-------+
| 100565 | SUSE_SLES-SP3-migration                  |    11.2 | x86_64       | -              |     - |

(*) NOTE: regarding (SLE10 and SLE11 only):
The Novell Customer Center (NCC) and nu.novell.com are not available anymore. SLE10 and SLE11 Systems still registered to the Novell Customer Center (NCC) can be migrated to the SUSE Customer Center (SCC) as outlined at:
https://www.suse.com/support/kb/doc/?id=000019508

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7016008
  • Creation Date: 18-Dec-2014
  • Modified Date:30-Dec-2021
    • Subscription Management Tool
    • SUSE Linux Enterprise Server

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