SCC migration/refresh fails when using multiple mirror credentials

This document (7016041) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager 2.1

Situation

With patch SUSE Manager 2.1 10083 (https://download.suse.com/Download?buildid=LTQ6mkaMJh0~) support for the SUSE Customer Center was introduced into SUSE Manager. After the patch was applied and multiple mirror credentials are specified in the webui, the migration to SCC fails or getting channel information stops working. Messages similar to the following may be seen in the tomcat main log file /var/log/tomcat6/catalina.out:

2015-01-06 10:42:51,545 [TP-Processor11] FATAL com.redhat.rhn.frontend.action.satellite.SCCConfigAction - a different object with the same identifier value was already associated with the session: [com.redhat.rhn.domain.scc.SCCRepository#1704] org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [com.redhat.rhn.domain.scc.SCCRepository#1704]

Resolution

A program temporary fix has been made available at:
https://ptf.suse.com/f2cf38b50ed714a8409693060195b235/sles11-sp3-susemanager-2.1/7842/x86_64/20150108-1/
Please download all RPMs to a temporary directory on the server and use
rpm -Fvh *rpm
from inside the temporary directory to apply the patched. In this case, the -F option will ensure only those packages get updated, that are already installed on the server. When done, please restart the spacewalk-service using
spacewalk-service restart

Cause


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7016041
  • Creation Date: 08-Jan-2015
  • Modified Date:03-Mar-2020
    • SUSE Manager

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center