LDAPS authentication from SLES not working, but LDAP does.

This document (7014087) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11

Situation

After building a new server (via automated tools), users in an ldap source could authenticate if using straight ldap (i.e. port 389), but not if using ldaps (port 636).

Resolution

Ensure the proper data is in both "Certificate Directory" and "CA Certificate File" fields under:

YaST
  -> Network Services
    -> LDAP client
      -> Client Settings tab

Cause

Server was built with a custom, automated build tool which did not populate these fields.

Additional Information

Utilizing YaST to activate LDAP authentication will help ensure a proper configuration.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014087
  • Creation Date: 11-Nov-2013
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback@suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center